logo

   上海鸣沃信息科技有限公司Shanghai MingWo Infor  Tec CO., LTD.

  最新动态
 
  技术文档  
您当前所在的位置是:技术文档

juniper的基本配置入门

2011-2-8 17:58:30

信息内容

juniper的基本配置入门

今天看了一个强人写的juniper基本配置,觉得通俗易懂,整理出来如下:

1、进入配置模式: configure (基本就按cisco的config t理解)


2、进入下一层次: edit(进入某个模式配置,可以按cisco下的int et 1/0,router ospf等任何进入子模式的命令理解)

 
3、设置命令: set (设置命令,具体赋值使用,比如加ip地址,ospf中的什么命令等)

 


4、删除命令: delete (同no)

 
5、提交: commit (和cisco理解不同,cisco是命令一旦执行即生效,juniper是先放在一个叫“擦写块”,然后只有commit才能放在running config中,就这么理解即可)


6、空格键完成未敲完的单词(同cisco中的tab建)

 

7、juniper中的接口定义:(Cisco中的接口定义,比如et 1/1,serial 0/2等等)
Juniper中的接口定义如下:接口名称-大槽号/小槽号/端口号
接口名称包括:

at—ATM类的口;e1— E1接口;e3— E3接口;fe— 100M口;so— POS口;t1— T1口;t3— DS-3口;ge— GE口;fxp0是特殊的,代表管理网口的名称,固定的!  

例子:Fe-5/2/3 〔端口名称-大槽号/小槽号/端口号〕

看一个接口配置的基本例子:
####节选###########
interfaces {
fe-1/0/3 {
unit 0 {
family inet {
address 10.0.20.1/24;
}
family mpls
}
}
}
####节选结束#########

例:fe-1/0/3配置ipv4地址10.0.20.1/24。并且此接口支持mpls,如果这些配置是其他设备呢?cisco配置如下:

interface ethernet 7/10
ip address 10.0.20.1 255.255.255.0
mpls ip
exit

juniper方法有2:
方法一、从用户模式进入config模式,怎么进?当然用config命令了,然后依次直接使用命令:
set interface fe-1/0/3 unit 0 family inet address 10.0.20.1/24
set interface fe-1/0/3 unit 0 family mpls
方法二、 edit interface fe-1/0/3 unit 0 family inet
set address 10.0.20.1/24
up
set family mpls


解释一下上面的命令中的几个关键字段,和几个命令的区别:
unit 0配合使用,代表此接口的第一个逻辑口
family后有inet、inet6、mpls等,代表支持的协议
up到上层配置层,同dos中的cd ..
top到config的根层

 

8、设置设备hostname
root@# set system host-name host-name
设置管理网口的ip地址:
root@# set interfaces fxp0 unit 0 family inet address 100.100.100.100/28

9、显示配置,在用户模式下:show config
在特权模式下:show

10、静态路由的配置方法:

routing-options {
static {
route 192.168.2.2/32 next-hop 192.168.2.2;
}
}
对应命令:set routing-option static route 192.168.2.2/32 next-hop 192.168.2.2
或者:edit routing-option static
set route 192.168.2.2/32 next-hop 192.168.2.2

11、juniper端口怎么shut,no shut了
关闭端口

[edit]
juniper@M10# set interfaces fe-0/1/1 disable
打开端口:
[edit]
juniper@M10# delete interfaces fe-0/1/1 disable

juniper@M10# commit

12、验证端口状态,先退出配置模式
[edit]
juniper@M10# quit
查看端口状态:
juniper@M10> show interfaces fe-0/1/1
Physical interface: fe-0/1/1, Administratively down, Physical link is Down

[←]暂无内容 [→]暂无内容

                                                                                                   沪ICP备11005944号| 网站所有©上海鸣沃信息科技有限公司

思科防火墙 思科交换机 思科无线 思科路由器 CISCO交换机 CISCO防火墙 CISCO 无线CISCO路由器 思科租赁 思科交换机租赁 思科无线租赁 思科防火墙租赁 CISCO租赁 CISCO无线租赁 CISCO交换机租赁 CISCO防火墙租赁